AppZen AAP Inbox - Email Delivery Warning
Incident Report for AppZen
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 11:59 PST
Monitoring
Hi There,

We have identified an issue with AppZen AAP Inbox Email Delivery. Customers may have received an email delivery failure warning.

The issue with Email Delivery occurred due to a change in DNS Entry which wiped out the DNS for the appzen.ai domain and resulted in email delivery failure. The issue has been fixed now, and further we are monitoring the incoming emails. No action is required from the customer end for now and we will update if any action is required.

We regret the inconvenience caused due to this.

Regards,
AppZen Support Team
Posted Nov 17, 2023 - 10:22 PST
This incident affected: AppZen Autonomous AP (Invoice Processing).