Concur US Outage - 4th Mar 2024
Incident Report for AppZen
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 17:08 PST
Update
Hi There,

The Concur issue is resolved & we are back up online.

We regret the inconvenience caused due to this.

Regards,
AppZen Support Team
Posted Mar 04, 2024 - 18:05 PST
Monitoring
We are staying in communication with the Concur Dev team and are working to receive further updates.
Posted Mar 04, 2024 - 14:31 PST
Identified
Concur is experiencing an outage in the US. We will do the best we can to keep you updated on the progress of the situation. This will affect the use of our solution for customers using the Concur platform. You can access the Concur Status Page here. https://open.concur.com/#public_sector
Posted Mar 04, 2024 - 10:37 PST
This incident affected: Expense Audit (Expense Audit).