Invoice & Expense Report Ingestion Delay

Incident Report for AppZen

Resolved

EA and AAP processing are back to normal processing speed & issue has been resolved.
Posted May 13, 2025 - 21:44 PDT

Investigating

We are currently experiencing a degradation in service related to a delay in the ingestion of some Invoices & Expense Reports. We apologize for any inconvenience as our teams work with urgency to resolve.
Posted May 13, 2025 - 13:05 PDT
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (Invoice Processing).