Slowness in auditing reports and ingestion of invoices

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted May 14, 2025 - 22:17 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 15:25 PDT

Investigating

We are currently experiencing a slowness in service related to the ingestion of some Invoices & auditing of expense reports. We apologize for any inconvenience as our teams are actively working to resolve this with urgency.
Posted May 14, 2025 - 03:12 PDT
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (Invoice Processing).